using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhref=""([^""]*[?&;]fref=fr_tab(?:[&;][^""]*)?)""";
string input = @"href=""?fref=fr_tab""
href=""https://www.test.com?fref=fr_tab""
href=""https://www.test.com?a=1&fref=fr_tab""
href=""https://www.test.com?a=1;fref=fr_tab""
href=""https://www.test.com?a=1;fref=fr_tab;b=2""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}