const regex = /\bhref="([^"]*[?&;]fref=fr_tab(?:[&;][^"]*)?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhref="([^"]*[?&;]fref=fr_tab(?:[&;][^"]*)?)"', 'gm')
const str = `href="?fref=fr_tab"
href="https://www.test.com?fref=fr_tab"
href="https://www.test.com?a=1&fref=fr_tab"
href="https://www.test.com?a=1;fref=fr_tab"
href="https://www.test.com?a=1;fref=fr_tab;b=2"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}