// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\bhref="([^"]*[?&;]fref=fr_tab(?:[&;][^"]*)?)""#).unwrap();
let string = "href=\"?fref=fr_tab\"
href=\"https://www.test.com?fref=fr_tab\"
href=\"https://www.test.com?a=1&fref=fr_tab\"
href=\"https://www.test.com?a=1;fref=fr_tab\"
href=\"https://www.test.com?a=1;fref=fr_tab;b=2\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}