use strict;
my $str = ' \'asdf\'+\'asdf\'+\'we\' + 1';
my $regex = qr/'([^']*')/p;
my $subst = '<<$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";