import re
regex = re.compile(r"'([^']*')")
test_str = " 'asdf'+'asdf'+'we' + 1"
subst = "<<$1"
result = regex.sub(subst, test_str)
if result:
print(result)