using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\().*?(?=\))";
string substitution = @"test";
string input = @"stringWithBraces()";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}