$re = '/(?<=\().*?(?=\))/';
$str = 'stringWithBraces()';
$subst = "test";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;