use strict;
my $str = 'stringWithBraces()';
my $regex = qr/(?<=\().*?(?=\))/p;
my $subst = 'test';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";