import re
regex = re.compile(r"(youtu(?:\.be|be\.com)\/(?:.*v(?:\/|=)|(?:.*\/)?)([\w'-]+))", flags=re.IGNORECASE)
test_str = ("http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo\n"
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
"http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I\n"
"http://www.youtube.com/user/SilkRoadTheatre#p/a/u/2/6dwqZw0j_jY\n"
"http://youtu.be/6dwqZw0j_jY\n"
"http://www.youtube.com/watch?v=6dwqZw0j_jY&feature=youtu.be\n"
"http://youtu.be/afa-5HQHiAs\n"
"http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo?rel=0\n"
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
"http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I\n"
"http://www.youtube.com/embed/nas1rJpm7wY?rel=0\n"
"http://www.youtube.com/watch?v=peFZbP64dsU")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")