const regex = new RegExp('([!?.])(?=\\S)', 'gm')
const str = `Hello there! This is Robert. Happy New Year!Are you surprised?Im not.`;
const subst = `\1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);