import re
regex = re.compile(r"([!?.])(?=\S)", flags=re.MULTILINE)
test_str = "Hello there! This is Robert. Happy New Year!Are you surprised?Im not."
subst = "\\1 "
result = regex.sub(subst, test_str)
if result:
print(result)