$re = '/([!?.])(?=\S)/m';
$str = 'Hello there! This is Robert. Happy New Year!Are you surprised?Im not.';
$subst = "\1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;