using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"study";
string input = @"In this study, we identified that rs7903146 has p = 5 * 10(-5) with 95% CI 0.97-1.12 and odds ratio 1.56. This result was obtained from a sample of American Indian recruited in California and Nevada. This SNP is known to affect the transcription and the pathway related to Three G-protein coupled receptors, the GRM7 metabotropic glutamate receptor, the orphan GPR154 and the HRH4 histamine receptor that are important to intracellular transduction.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}