import Foundation
let pattern = #"study"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"In this study, we identified that rs7903146 has p = 5 * 10(-5) with 95% CI 0.97-1.12 and odds ratio 1.56. This result was obtained from a sample of American Indian recruited in California and Nevada. This SNP is known to affect the transcription and the pathway related to Three G-protein coupled receptors, the GRM7 metabotropic glutamate receptor, the orphan GPR154 and the HRH4 histamine receptor that are important to intracellular transduction."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}