// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"study").unwrap();
let string = "In this study, we identified that rs7903146 has p = 5 * 10(-5) with 95% CI 0.97-1.12 and odds ratio 1.56. This result was obtained from a sample of American Indian recruited in California and Nevada. This SNP is known to affect the transcription and the pathway related to Three G-protein coupled receptors, the GRM7 metabotropic glutamate receptor, the orphan GPR154 and the HRH4 histamine receptor that are important to intracellular transduction.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}