# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<field>[a-z0-9]*)=>)(?<value>\"[a-z0-9-_'/=> ]*\")"
test_str = ("FldSelectAllowAdd=>\"0\" FldSelectFilter=>\"\" FldSelectFilterFld=>\"\" FldSelectForceSelection=>\"0\" FldSelectMultiple=>\"0\" FldSelectSize=>\"\" FldSelectType=>\"Values\"\n"
"FldTagLnkDisp2=>\"\" FldTagLnkDisplay=>\"\" FldTagLnkDistinct=>\"0\" FldTagLnkFld=>\"\" FldTagLnkOrderBy=>\"\" FldTagLnkOrderType=>\"\" FldTagLnkTbl=>\"\"\n"
"FldTagAPrefix=>\"None\" FldTagASuffix=>\"\" FldTagATarget=>\"\" FldTagAType=>\"\" FldTagCols=>\"\" FldTagHiddenValue=>\"\" FldTagImgHeight=>\"\" FldTagImgWidth=>\"\" FldTagMaxLength=>\"\" FldTagRows=>\"\" FldTagSize=>\"\" FldTagValues=>\"\"\n"
"FldAdd=>\"0\" FldAddOpt=>\"1\" FldAggregate=>\"\" FldAjax=>\"0\" FldAlias=>\"0\" FldAlign=>\"\" FldAlt=>\"\" FldAttribute=>\"100\" FldAutoFill=>\"0\" FldAutoIncrement=>\"0\" FldAutoUpdateValue=>\"\"\n"
"FldBasicSearch=>\"0\" FldBold=>\"0\"\n"
"FldCaption=>\"Updated At\" FldCheckDuplicate=>\"0\" FldColumnWidth=>\"\" FldColumnWrap=>\"0\"\n"
"FldDefault=>\"\" FldDtFormat=>\"7\"\n"
"FldEdit=>\"0\" FldEditCustomAttributes=>\"\" FldEditTableField=>\"\" FldErrMsg=>\"\" FldExport=>\"0\" FldExtendedBasicSearch=>\"0\"\n"
"FldFmtType=>\"Date/Time\"\n"
"FldGenerate=>\"1\" FldGpDigits=>\"-2\" FldGroupBy=>\"0\" FldGroupByShowSummary=>\"0\"\n"
"FldHrefFld=>\"\" FldHrefFldOrig=>\"0\" FldHtmlTag=>\"TEXT\" FldHtmlTagReadOnly=>\"0\"\n"
"FldIncLeadDigit=>\"-2\" FldIsPrimaryKey=>\"0\" FldItalic=>\"0\"\n"
"FldList=>\"0\"\n"
"FldMax=>\"\" FldMemoCRLFReplace=>\"0\" FldMemoMaxLength=>\"0\" FldMin=>\"\" FldMultiUpdate=>\"0\"\n"
"FldNumDigits=>\"0\"\n"
"FldOrder=>\"\" FldOrderBy=>\"0\"\n"
"FldPageIndex=>\"1\" FldParentSelect=>\"\" FldPopCalendar=>\"0\"\n"
"FldQuoteE=>\"'\" FldQuoteS=>\"'\"\n"
"FldRegister=>\"0\" FldRepeatColumns=>\"0\" FldReq=>\"0\" FldRequired=>\"0\" FldResizeHeight=>\"0\" FldResizeQuality=>\"75\" FldResizeWidth=>\"0\" FldRptAggAvg=>\"0\" FldRptAggMax=>\"0\" FldRptAggMin=>\"0\" FldRptAggSum=>\"0\"\n"
"FldSearch=>\"0\" FldSize=>\"26\" FldSourceField=>\"\" FldSourceName=>\"\" FldSourceTable=>\"\" FldSrchOpr=>\"=>\" FldSrchOpr2=>\"\" FldStrFunc=>\"\" FldSupport=>\"1\"\n"
"FldTitle=>\"\" FldType=>\"135\" FldTypeName=>\"TIMESTAMP\"\n"
"FldUniqueIdx=>\"0\" FldUploadPath=>\"\" FldUploadResize=>\"0\" FldUseDHTMLEditor=>\"0\" FldUseParen=>\"-2\"\n"
"FldValidate=>\"EURODATE\" FldView=>\"0\" FldViewCustomAttributes=>\"\" FldViewTag=>\"FORMATTED TEXT\" FldViewThumbnail=>\"0\"\n"
"FldZeroLen=>\"1\"\n"
"FileNameFld=>\"\" FileSizeFld=>\"\" FileTypeFld=>\"\"\n"
"ImageHeightFld=>\"\" ImageWidthFld=>\"\"\n"
"NativeDataType=>\"7\"")
subst = "'${field}' => ${value},"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.