package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi).*The Girl Is Mine.*`)
var str = `The Girl Is Mine (feat. Paul McCartney)
The Girl Is fine (feat. Paul McIcetea)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}