// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi).*The Girl Is Mine.*").unwrap();
let string = "The Girl Is Mine (feat. Paul McCartney)
The Girl Is fine (feat. Paul McIcetea)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}