$re = '/.*The Girl Is Mine.*/mi';
$str = 'The Girl Is Mine (feat. Paul McCartney)
The Girl Is fine (feat. Paul McIcetea)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);