#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bEmail:\s*<a\s[^<>]*\bhref="mailto:([^"]+)""
Local $sString = "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">" & @CRLF & _
"<html xmlns="http://www.w3.org/1999/xhtml">" & @CRLF & _
"<html>" & @CRLF & _
"<head></head>" & @CRLF & _
"<body>" & @CRLF & _
"<a name="top"></a>Back to Category Index</a></p>" & @CRLF & _
"<p>-----------------------------------<br/></p>" & @CRLF & _
"" & @CRLF & _
"67)<a name="e1h1" id="e1h1"></a> Summary: Solar Eclipse 2024 Travel" & @CRLF & _
"<br/><br/>" & @CRLF & _
"<p>Name: laure gem wilson" & @CRLF & _
"Roadtrippers" & @CRLF & _
"</p>Category: Travel" & @CRLF & _
"<br/><br/>" & @CRLF & _
"Email: <a href="mailto:query-e1h1@email.net">query-e1h1@email.net</a>" & @CRLF & _
"<br/><br/>" & @CRLF & _
"Outlet: Roadtrip<br/><br/>" & @CRLF & _
"Deadline: 7:00 PM EST - 8 July" & @CRLF & _
"<br/><br/>" & @CRLF & _
"<p>" & @CRLF & _
"Query: " & @CRLF & _
"<br/><br/>" & @CRLF & _
"Hi, I am on assignment to write a feature about planning a road<br/>trip to experience the Solar Eclipse 2024, including path of<br/>totality, advice about viewing, and recommendations for when and<br/>where to book accommodations, thanks!<br/>" & @CRLF & _
"</p>" & @CRLF & _
"<p>" & @CRLF & _
"Requirements: " & @CRLF & _
"<br /><br />" & @CRLF & _
"Must be domestic USA<br/>" & @CRLF & _
"</p>" & @CRLF & _
"<p><a href="#top">Back to Top</a> <a href="#Travel">Back to Category Index</a></p>" & @CRLF & _
"<p>-----------------------------------<br/>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")