# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bEmail:\s*<a\s[^<>]*\bhref=\"mailto:([^\"]+)\""
test_str = ("<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">\n"
"<html xmlns=\"http://www.w3.org/1999/xhtml\">\n"
"<html>\n"
"<head></head>\n"
"<body>\n"
"<a name=\"top\"></a>Back to Category Index</a></p>\n"
"<p>-----------------------------------<br/></p>\n\n"
"67)<a name=\"e1h1\" id=\"e1h1\"></a> Summary: Solar Eclipse 2024 Travel\n"
"<br/><br/>\n"
"<p>Name: laure gem wilson\n"
"Roadtrippers\n"
"</p>Category: Travel\n"
"<br/><br/>\n"
"Email: <a href=\"mailto:query-e1h1@email.net\">query-e1h1@email.net</a>\n"
"<br/><br/>\n"
"Outlet: Roadtrip<br/><br/>\n"
"Deadline: 7:00 PM EST - 8 July\n"
"<br/><br/>\n"
"<p>\n"
"Query: \n"
"<br/><br/>\n"
"Hi, I am on assignment to write a feature about planning a road<br/>trip to experience the Solar Eclipse 2024, including path of<br/>totality, advice about viewing, and recommendations for when and<br/>where to book accommodations, thanks!<br/>\n"
"</p>\n"
"<p>\n"
"Requirements: \n"
"<br /><br />\n"
"Must be domestic USA<br/>\n"
"</p>\n"
"<p><a href=\"#top\">Back to Top</a> <a href=\"#Travel\">Back to Category Index</a></p>\n"
"<p>-----------------------------------<br/>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.