$re = '/\bEmail:\s*<a\s[^<>]*\bhref="mailto:([^"]+)"/m';
$str = '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<html>
<head></head>
<body>
<a name="top"></a>Back to Category Index</a></p>
<p>-----------------------------------<br/></p>
67)<a name="e1h1" id="e1h1"></a> Summary: Solar Eclipse 2024 Travel
<br/><br/>
<p>Name: laure gem wilson
Roadtrippers
</p>Category: Travel
<br/><br/>
Email: <a href="mailto:query-e1h1@email.net">query-e1h1@email.net</a>
<br/><br/>
Outlet: Roadtrip<br/><br/>
Deadline: 7:00 PM EST - 8 July
<br/><br/>
<p>
Query:
<br/><br/>
Hi, I am on assignment to write a feature about planning a road<br/>trip to experience the Solar Eclipse 2024, including path of<br/>totality, advice about viewing, and recommendations for when and<br/>where to book accommodations, thanks!<br/>
</p>
<p>
Requirements:
<br /><br />
Must be domestic USA<br/>
</p>
<p><a href="#top">Back to Top</a> <a href="#Travel">Back to Category Index</a></p>
<p>-----------------------------------<br/>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);