import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\w+)[^>]*>(?>[\\p{Z}\\p{C}]|<br\\b[^>]*>|&(?:(?:nb|thin|zwnb|e[nm])sp|zwnj|#xfeff|#xa0|#160|#65279);|(?R))*</\\1>";
final String string = "<strong class=\"a b\"><b></b> </strong>\n"
+ "<strong class=\"a b\"> <br class=\"a b\" /></strong>\n"
+ "<br class=\"a b\" />\n"
+ "<strong class=\"a b\"><br> \n"
+ " <strong>\n"
+ " <b><br /> </b>\n"
+ " </strong>\n"
+ "</strong>\n"
+ "abc\n"
+ "<strong class=\"a b\"><br class=\"a b\" /><br class=\"a b\" /></strong>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}