use strict;
my $str = '<strong class="a b"><b></b> </strong>
<strong class="a b"> <br class="a b" /></strong>
<br class="a b" />
<strong class="a b"><br>
<strong>
<b><br /> </b>
</strong>
</strong>
abc
<strong class="a b"><br class="a b" /><br class="a b" /></strong>';
my $regex = qr~<(\w+)[^>]*>(?>[\p{Z}\p{C}]|<br\b[^>]*>|&(?:(?:nb|thin|zwnb|e[nm])sp|zwnj|#xfeff|#xa0|#160|#65279);|(?R))*</\1>~up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}