$re = '~<(\w+)[^>]*>(?>[\p{Z}\p{C}]|<br\b[^>]*>|&(?:(?:nb|thin|zwnb|e[nm])sp|zwnj|#xfeff|#xa0|#160|#65279);|(?R))*</\1>~u';
$str = '<strong class="a b"><b></b> </strong>
<strong class="a b"> <br class="a b" /></strong>
<br class="a b" />
<strong class="a b"><br>
<strong>
<b><br /> </b>
</strong>
</strong>
abc
<strong class="a b"><br class="a b" /><br class="a b" /></strong>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);