#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?!914)\d{3}\b"
Local $sString = "123" & @CRLF & _
"235" & @CRLF & _
"456" & @CRLF & _
"1000" & @CRLF & _
"910 911 912 913" & @CRLF & _
" 914" & @CRLF & _
"915 916"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")