import re
regex = re.compile(r"\b(?!914)\d{3}\b")
test_str = ("123\n"
"235\n"
"456\n"
"1000\n"
"910 911 912 913\n"
" 914\n"
"915 916")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")