$re = '/\b(?!914)\d{3}\b/';
$str = '123
235
456
1000
910 911 912 913
914
915 916';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);