using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"- (.*?)(?=\s+\((?:not|yes)\)|$)";
string input = @"this my line - Fine (R/S)
more date - I like this (not)
date - output (yes)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}