re = /- (.*?)(?=\s+\((?:not|yes)\)|$)/m
str = 'this my line - Fine (R/S)
more date - I like this (not)
date - output (yes)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end