$re = '/- (.*?)(?=\s+\((?:not|yes)\)|$)/m';
$str = 'this my line - Fine (R/S)
more date - I like this (not)
date - output (yes)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);