import re
regex = re.compile(r"(?<=_V1_)(.+?)(?=.jpg)")
test_str = "https://m.media-amazon.com/images/M/MV5BYWNlMWMxOWYtZWI0Mi00ZTg0LWEwZTMtZTEzZDY0NzAxYTA4XkEyXkFqcGdeQXVyMTQxNzMzNDI@._V1_UX182_CR0,0,182,268_AL_.jpg"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)