#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^[A-RT-Z]*S[A-Z]*,[^,\n]*,)[^,\n]+(?=,)"
Local $sString = "BB,21,1.750000,0.000000," & @CRLF & _
"AS,21.5,3.250000,-0.187500" & @CRLF & _
"BS,21,3.250000,-0.187500" & @CRLF & _
"CS, ,1.750000,-0.375000" & @CRLF & _
"DS,1,30.375000,-0.375000" & @CRLF & _
"QA,aa,30.375000,-0.375000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")