re = /(?<=^[A-RT-Z]*S[A-Z]*,[^,\n]*,)[^,\n]+(?=,)/m
str = 'BB,21,1.750000,0.000000,
AS,21.5,3.250000,-0.187500
BS,21,3.250000,-0.187500
CS, ,1.750000,-0.375000
DS,1,30.375000,-0.375000
QA,aa,30.375000,-0.375000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end