import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^[A-RT-Z]*S[A-Z]*,[^,\\n]*,)[^,\\n]+(?=,)";
final String string = "BB,21,1.750000,0.000000,\n"
+ "AS,21.5,3.250000,-0.187500\n"
+ "BS,21,3.250000,-0.187500\n"
+ "CS, ,1.750000,-0.375000\n"
+ "DS,1,30.375000,-0.375000\n"
+ "QA,aa,30.375000,-0.375000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}