using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((close|fix|address)e?(s|d)? )?(ticket|bug|tracker item|issue)s?:? *([\d ,\+&#and]+)";
string input = @"Fix issue 12564: add std.range.walkBack";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}