package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((close|fix|address)e?(s|d)? )?(ticket|bug|tracker item|issue)s?:? *([\d ,\+&#and]+)`)
var str = `Fix issue 12564: add std.range.walkBack`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}