re = /((close|fix|address)e?(s|d)? )?(ticket|bug|tracker item|issue)s?:? *([\d ,\+&#and]+)/i
str = 'Fix issue 12564: add std.range.walkBack'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end