$re = '/^(?!(.*?\*){2,}|.*? |\*$).*?\*.*$/m';
$str = 'test*
*_test
test*something
test
*
test_**
**_test
test*something*
test *something
test *';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);