re = /^(?!(.*?\*){2,}|.*? |\*$).*?\*.*$/m
str = 'test*
*_test
test*something
test
*
test_**
**_test
test*something*
test *something
test *'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end