#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\S+) (?=(?s:.)*?\1.*).*"
Local $sString = "wsmith jul/12/12" & @CRLF & _
"bwillis jul/13/13" & @CRLF & _
"wsmith jul/14/12" & @CRLF & _
"bwillis jul/13/13" & @CRLF & _
"tcruise jul/12/12" & @CRLF & _
"wsmith jul/14/12" & @CRLF & _
"tcruise jul/12/12" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")