using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+) (?=(?s:.)*?\1.*).*";
string input = @"wsmith jul/12/12
bwillis jul/13/13
wsmith jul/14/12
bwillis jul/13/13
tcruise jul/12/12
wsmith jul/14/12
tcruise jul/12/12
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}