re = /^(\S+) (?=(?s:.)*?\1.*).*/m
str = 'wsmith jul/12/12
bwillis jul/13/13
wsmith jul/14/12
bwillis jul/13/13
tcruise jul/12/12
wsmith jul/14/12
tcruise jul/12/12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end