using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http:\/\/([^\/]*)\/(.*)$";
string input = @"http://www.example.com/
http://www.example.com/go
http://www.example.com/contact/
http://www.example.com/links/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}