re = /^http:\/\/([^\/]*)\/(.*)$/m
str = 'http://www.example.com/
http://www.example.com/go
http://www.example.com/contact/
http://www.example.com/links/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end