$re = '/^http:\/\/([^\/]*)\/(.*)$/m';
$str = 'http://www.example.com/
http://www.example.com/go
http://www.example.com/contact/
http://www.example.com/links/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);