$re = '/([A-Z])(?=[A-Z][a-z])|([^A-Z])(?=[A-Z])|([A-Za-z])(?=[^A-Za-z])/m';
$str = 'MMa ';
$subst = "$1$2$3 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;