re = /([A-Z])(?=[A-Z][a-z])|([^A-Z])(?=[A-Z])|([A-Za-z])(?=[^A-Za-z])/m
str = 'MMa '
subst = '$1$2$3 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result