import re
regex = re.compile(r"([A-Z])(?=[A-Z][a-z])|([^A-Z])(?=[A-Z])|([A-Za-z])(?=[^A-Za-z])", flags=re.MULTILINE)
test_str = "MMa "
subst = "$1$2$3 "
result = regex.sub(subst, test_str)
if result:
print(result)