const regex = /^\d$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d$', 'gm')
const str = `0
1
3
9
10
11
12
`;
const subst = `0\0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);